lkml.org 
[lkml]   [2011]   [Feb]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/6] x86: move ioapic_irq_destination_types

* Henrik Kretzschmar <henne@nachtwindheim.de> wrote:

> +++ b/arch/x86/include/asm/apicdef.h
> @@ -426,4 +426,16 @@ struct local_apic {
> #else
> #define BAD_APICID 0xFFFFu
> #endif
> +
> +enum ioapic_irq_destination_types {
> + dest_Fixed = 0,
> + dest_LowestPrio = 1,
> + dest_SMI = 2,
> + dest__reserved_1 = 3,
> + dest_NMI = 4,
> + dest_INIT = 5,
> + dest__reserved_2 = 6,
> + dest_ExtINT = 7
> +};

one very small request, while we are moving it could you please align the value
enumeration vertically? Something like:

enum ioapic_irq_destination_types {

dest_Fixed = 0,
dest_LowestPrio = 1,
dest_SMI = 2,
dest__reserved_1 = 3,
dest_NMI = 4,
dest_INIT = 5,
dest__reserved_2 = 6,
dest_ExtINT = 7
};

... would be much more readable, right?

Thanks,

Ingo


\
 
 \ /
  Last update: 2011-02-14 12:09    [W:0.090 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site