lkml.org 
[lkml]   [2011]   [Oct]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 3/4] ata_piix: CodingStyle fixes
On 10/13/2011 09:43 AM, Bartlomiej Zolnierkiewicz wrote:
> From: Bartlomiej Zolnierkiewicz<bzolnier@gmail.com>
> Subject: [PATCH] ata_piix: CodingStyle fixes
>
> CodingStyle fixes for piix_port_info[].
>
> Signed-off-by: Bartlomiej Zolnierkiewicz<bzolnier@gmail.com>
> ---
> drivers/ata/ata_piix.c | 68 ++++++++++++++-----------------------------------
> 1 file changed, 20 insertions(+), 48 deletions(-)
>
> Index: b/drivers/ata/ata_piix.c
> ===================================================================
> --- a/drivers/ata/ata_piix.c
> +++ b/drivers/ata/ata_piix.c
> @@ -473,131 +473,103 @@ static const struct piix_map_db *piix_ma
> };
>
> static struct ata_port_info piix_port_info[] = {
> - [piix_pata_mwdma] = /* PIIX3 MWDMA only */
> - {
> + [piix_pata_mwdma] = { /* PIIX3 MWDMA only */
> .flags = PIIX_PATA_FLAGS,
> .pio_mask = ATA_PIO4,
> - .mwdma_mask = ATA_MWDMA12_ONLY, /* mwdma1-2 ?? CHECK 0 should be ok but slow */
> + .mwdma_mask = ATA_MWDMA12_ONLY, /* check if MWDMA0 is OK */
> .port_ops =&piix_pata_ops,
> },

Having been the perpetrator of this "awful" coding style, I think it is
fine and more readable as-is... :)




\
 
 \ /
  Last update: 2011-10-14 19:39    [W:0.043 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site