lkml.org 
[lkml]   [2011]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] dev: use ifindex hash for dev_seq_ops
On Wed, 12 Oct 2011 12:57:26 +0300
Mihai Maruseac <mihai.maruseac@gmail.com> wrote:

It looks like you lost the ability to seek back and read the header
(start token). How is the header handled, is possible to rewind
the file and read it over again?


> +static inline struct net_device *next_dev(struct seq_file *seq, loff_t *pos)
> +{
> + struct dev_iter_state *state = seq->private;
> + struct net *net = seq_file_net(seq);
> + struct net_device *dev = NULL;
> + loff_t off;
> +
> + ++*pos;
> + dev = dev_get_by_index_rcu(net, state->ifindex);

Looks good a couple of minor nits.

1. The function should not be inline, since it is in no way performance
critical. The compiler will probably inline it anyway.

2. dev does not have to be initialized since it is assigned a few
lines later. Most programmers are trained now to always initialize
variables, but often it is unnecessary.

3. The name next_dev() is a little generic; maybe a better name.


\
 
 \ /
  Last update: 2011-10-12 17:53    [W:0.114 / U:0.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site