lkml.org 
[lkml]   [2008]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: kernel.h: add ARRAY_AND_SIZE() macro to complement ARRAY_SIZE().
Alexey Dobriyan wrote:
> On Fri, Sep 19, 2008 at 08:28:45AM -0700, Russ Dill wrote:
>> My vote is for ARRAY_AND_SIZE to spread far and wide across the land.
>> ARRAY_SIZE is already very safe, as it has a __must_be_array macro
>> built in. So ARRAY_AND_SIZE is even safer, as it prevents you from
>> mixing up two different arrays. It also reduces line length and makes
>> driver and device (usually platform_device) registration code easier
>> to read.
>
> It also spreads ARRAY_SIZE misnaming futher.

You still haven't explained what's misnamed about it, nor suggested a
better name.

> It introduces one more core macro and quite pointless one. I can't
> personally recall a single bug where sizeof() was taken from another
> array.

You haven't written a lot of machine definitions then. When adding
platform devices for an embedded platform one has to write a lot of
boilerplate like this:

platform_add_devices(n30_devices, ARRAY_SIZE(n30_devices));

and it is much too easy to copy paste that line and miss one of the
references.

> It creates interesting confusion point: ARRAY_AND_SIZE is about array
> and it's size. What ARRAY_SIZE is about then?

ARRAY_AND_SIZE -> (An) array and (its) size

ARRAY_SIZE -> (The) array size

Sure, you could write ARRAY_AND_ITS_SIZE, but would that really make
anyone happy? Cobol went out of fashion a long time ago.

/Christer



\
 
 \ /
  Last update: 2008-09-20 15:07    [W:0.113 / U:0.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site