lkml.org 
[lkml]   [2008]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [bug?] tg3: Failed to load firmware "tigon/tg3_tso.bin"
From
From: Alan Cox <alan@lxorguk.ukuu.org.uk>
Date: Mon, 7 Jul 2008 19:30:08 +0100

> I don't see why it should be David's job to add every conceivable feature
> to the code.

David's changes prevent something from working, which works today.

Usually we refer to that as a regression.

And usually, we rely on the patch author to fix regressions they add,
and failing that we revert their work.

Bringing up this SATA scarecrow and trying to make Jeff look
inconsistent is not winning your arguments any extra points.
Especially not with me.

You also mentioned something about how similar arguments as ours
were made when modules were proposed as a feature. Well, I can
say only two things about that:

1) I could still build a static kernel image and use it as-is after
the changes to support modules were added to the kernel. In fact I
still largely do not use modules at all during my own kernel work.

This is completely unlike what David is doing here, where the
previous status quo will cease working.

2) You cannot deny the fine mess we have with proprietary modules and
such these days. It has been quite the pandora's box over time.



\
 
 \ /
  Last update: 2008-07-07 22:51    [W:0.181 / U:0.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site