lkml.org 
[lkml]   [2008]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] bnx2 - use request_firmware()
From
Date
On Mon, 2008-07-07 at 02:03 -0700, David Woodhouse wrote:
> The real concern I see would be if you make an incompatible change in
> the firmware when you add the new feature -- so that the older drivers
> would no longer work with the new firmware. But mostly, people don't
> do
> that -- I'm guessing that your planned new firmware should work just
> fine with older drivers, and the older drivers just won't use the new
> feature?
>
> If it _is_ backward-incompatible, that's not really a problem. The
> solution is relatively simple; you just change the name of the
> firmware
> file that gets requested by the new driver -- so the old driver
> continues to request the old name, and get the firmware that works
> with
> it. It's a bit like an soname in userspace libraries, in that respect.

The driver is not guaranteed to be backward or forward compatible with
the firmware. It may be forward compatible in most cases (new firmware
may work with older driver) but there is no guarantee because it is
simply not necessary in the current model.

We also only test 1 driver + 1 firmware and no other combinations.
Separating the 2 makes things more complicated and prone to random
failures.





\
 
 \ /
  Last update: 2008-07-07 20:57    [W:0.066 / U:0.696 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site