lkml.org 
[lkml]   [2008]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectstrange freeze with VIA C7 dedicated server and libc 2.6.1
 hi all

I am using gentoo linux on 3 boxes ( low cost dedicated servers ) who
are using VIA C7 CPU, all of them were running very well for
more than 1 year.

I recently emerge --sync and emerge -DNatuv world ( gentoo updates )
on 2 of the boxes.

The 2 upgraded boxes ( now running glibc-2.6.1 )are now now freezing very
often, most often when under heavy load ( >2 load )

There is nothing in the logs, I checked syslog, kern.log . . . nothing, no
clue.
the other box, still running glibc-2.5-r4 , is working very well as before.

I tried many kernel, from 2.6.18 to 2.6.24, with and without hardened profile,
its the same

I'm not the only one, many people in france had this problem, debian users who
downgraded libc could go back to a stable server, but with gentoo, downgrading
libc seems pretty dangerous.

All the reported problems are in french cause it seems only dedibox (
http://dedibox.fr ) provides low cost servers using VIA C7 processor ), if
needed i can provide many webpages where people describe the problem in french
( google "dedibox freeze libc" gives some ), but I found nothing in english, if
you contact dedibox.fr admins they will confirm the problem, perhaps they even
could accept to provide a box for testing, who knows . . .

I have nothing to give you, nothing in the log, the box just stop working as
if power had been switched off

The problem happened at least on debian and gentoo which are the most used
linux distros on dedibox VIA C7 servers.

The exact processor is :
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 10
model name : VIA Esther processor 2000MHz
stepping : 9
cpu MHz : 1995.084
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge cmov pat
clflush acpi mmx fxsr sse sse2 tm pni est tm2 rng rng_en ace ace_en ace2
ace2_en phe phe_en pmm pmm_en
bogomips : 3994.49
clflush size : 64

Reproducible: Always

Steps to Reproduce:
1. box using VIA C7 processor with glibc
2. heavy load >2
3. wait 1 or 2 hours

The complete bug report with attachments ( logs and kernel .config )
and gentoo maintainers comments is here :

http://bugs.gentoo.org/show_bug.cgi?id=228263

I have no clue this is a linux kernel bug, since all the kernels I
tried ( from 2.6.18 to 2.6.24 ) are working perfectly before upgrading
to the new libc, but the gentoo maintainers finally told me I should
post on the LKML.

here is the last comment from the gentoo maintainer :
"If the kernel completely locks up then that is a kernel bug or a hardware bug.
It shouldn't be possible to lock up the kernel, regardless of what userland
such as glibc does. Presumably the newer glibc is doing something different
that is triggering the bug. Regardless of what that is and whether it should be
doing it, it shouldn't completely hang the kernel."

Feel free to ask more details, I'll be happy to provide answers.
( no need to cc me I subscribed to follow this problem )

--
Cordialement

William Waisse
http://waisse.org | http://neoskills.com
http://cahierspip.ww7.be | http://feeder.ww7.be


\
 
 \ /
  Last update: 2008-06-24 05:03    [W:0.079 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site