[lkml]   [2008]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH] x86:Use cpu_khz for loops_per_jiffy calculation

* Alok Kataria <> wrote:

> > but there's another problem as well: why are generic files
> > (init/calibrate.c and include/linux/delay.h) using something that is
> > named in an x86-specific way - lpj_tsc ? (TSC is an x86 concept)
> calibrate_delay_direct was using some variables with "tsc" as the
> prefix (tsc_rate_min/max) i thought of using lpj_tsc. And also
> IMO, lpj_tsc explains how is this variable initialized. But thinking
> about it, maybe we should rename it to "lpj_timer" ?

ok. But instead of 'lpj_timer' i'd suggest to use something like
'lpj_fine' - as this really is about finegrained measurements.

I'd suggest a delta patch against tip/master that renames all those
tsc_* variables to fine_*. So tsc_rate_min would become fine_rate_min,


 \ /
  Last update: 2008-06-24 01:51    [W:0.074 / U:0.736 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site