lkml.org 
[lkml]   [2008]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: USB HID: Missing keys on Gyration Media Center Universal Remote Control
On Mon, 16 Jun 2008, Philippe Troin wrote:

> Jiri & all,
> What's the status on this bug?
> I used this patch for 2.6.24:
> diff --git a/drivers/hid/hid-input.c b/drivers/hid/hid-input.c
> index 0b27da7..fc6e77e 100644
> --- a/drivers/hid/hid-input.c
> +++ b/drivers/hid/hid-input.c
> @@ -802,6 +802,7 @@ static void hidinput_configure_usage(struct hid_input *hidinput, struct hid_fiel
> case HID_UP_LOGIVENDOR:
> set_bit(EV_REP, input->evbit);
> switch(usage->hid & HID_USAGE) {
> + case 0x000: map_key_clear(KEY_TV);
> /* Reported on Logitech Ultra X Media Remote */
> case 0x004: map_key_clear(KEY_AGAIN); break;
> case 0x00d: map_key_clear(KEY_HOME); break;
> @@ -1039,6 +1040,28 @@ void hidinput_hid_event(struct hid_device *hid, struct hid_field *field, struct
> return;
> }
>
> + /* "Sleep" key */
> + if (hid->vendor == 0x0c16 && hid->product == 0x0002 &&
> + ((usage->hid & HID_USAGE_PAGE) == HID_UP_GENDESK) &&
> + ((usage->hid & 0xf0) == 0x80) &&
> + ((usage->hid & 0xf) == 0x2)) {
> + input_event(input, usage->type, usage->code, 1);
> + input_sync(input);
> + input_event(input, usage->type, usage->code, 0);
> + input_sync(input);
> + return;
> + }
> + /* "TV" key */
> + if (hid->vendor == 0x0c16 && hid->product == 0x0002 &&
> + ((usage->hid & HID_USAGE_PAGE) == HID_UP_LOGIVENDOR) &&
> + ((usage->hid & HID_USAGE) == 0x0000)) {
> + input_event(input, usage->type, usage->code, 1);
> + input_sync(input);
> + input_event(input, usage->type, usage->code, 0);
> + input_sync(input);
> + return;
> + }
> +
> /* Handling MS keyboards special buttons */
> if (IS_MS_KB(hid) && usage->hid == (HID_UP_MSVENDOR | 0xff05)) {
> int key = 0;
> It was working fine.

Hi,

The patch didn't add complete support for this device, there still has
been problem with "TV" key, and I have asked Adolfo to perform a test with
debugging patch, but there seems to be no response so far [1]

Adolfo (added to CC), has there been any progress, so that we could
proceed with merging the patch adding proper support for this HW?

Thanks,

[1]

--
Jiri Kosina
SUSE Labs


\
 
 \ /
  Last update: 2008-06-17 16:03    [W:0.087 / U:0.088 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site