lkml.org 
[lkml]   [2008]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Make for_each_cpu_mask a bit smaller
On Sun, May 11, 2008 at 03:50:39PM +0200, Alexander van Heukelum wrote:
> #if NR_CPUS > 1
> -#define for_each_cpu_mask(cpu, mask) \
> - for ((cpu) = first_cpu(mask); \
> - (cpu) < NR_CPUS; \
> - (cpu) = next_cpu((cpu), (mask)))
> +#define for_each_cpu_mask(cpu, mask) \
> + for ((cpu) = 0; \
> + (cpu) = find_next_cpu_mask((cpu), &(mask)), \
> + (cpu) < NR_CPUS; (cpu)++)

For anyone else having similar cognitive dissonance while reading this
thinking "But won't the first call to find_next_cpu_mask return a number
> 0", the answer is "no, find_next_bit returns the next set bit that's
>= the number passed in, which is why we need both the cpu++ and
find_next_cpu_mask".

> +int find_next_cpu_mask(int n, const cpumask_t *srcp)
> +{
> + return find_next_bit(srcp->bits, NR_CPUS, n);
> +}
> +EXPORT_SYMBOL(find_next_cpu_mask);

Maybe a better name for this function would help. I can't think of a
good one right now though.

--
Intel are signing my paycheques ... these opinions are still mine
"Bill, look, we understand that you're interested in selling us this
operating system, but compare it to ours. We can't possibly take such
a retrograde step."


\
 
 \ /
  Last update: 2008-05-11 17:27    [W:0.085 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site