lkml.org 
[lkml]   [2008]   [Apr]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 1 of 6] hotplug-memory: refactor online_pages to separate zone growth from page onlining
From
Date

On Thu, 2008-04-03 at 17:05 -0700, Jeremy Fitzhardinge wrote:
>
> +int prepare_online_pages(unsigned long pfn, unsigned long nr_pages)
> +{
> + int ret = notify_going_online(pfn, nr_pages);
> + if (ret)
> + return ret;
> +
> + grow_zone_span(pfn, pfn+nr_pages);
> return 0;
> +}

OK, after seeing this used in the Xen driver, I'm even less a fan of the
name. Mostly because it doesn't actually prepare *pages* to be onlined.
It prepares the zones/pgdats and notifies that pages might soon be
online. Can you think of any better names?

grow_and_notify...??

It's also a bit funky because you're calling the online notifiers, but
you're not actually onlining the pages, yet. Does that have any
repercussions?

-- Dave



\
 
 \ /
  Last update: 2008-04-04 03:11    [W:2.022 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site