lkml.org 
[lkml]   [2008]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
SubjectRe: x86: cleanup - rename VM_MASK to X86_VM_MASK
From
Date
On Fri, 2008-04-18 at 18:56 +0000, Linux Kernel Mailing List wrote:
> Gitweb: http://git.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
> Commit: 6b6891f9c545ccd45d6d8ddfd33ce27c22c271a7
> Parent: 6093015db2bd9e70cf20cdd23be1a50733baafdd
> Author: gorcunov@gmail.com <gorcunov@gmail.com>
> AuthorDate: Fri Mar 28 17:56:57 2008 +0300
> Committer: Ingo Molnar <mingo@elte.hu>
> CommitDate: Thu Apr 17 17:41:33 2008 +0200
>
> x86: cleanup - rename VM_MASK to X86_VM_MASK
>
> This patch renames VM_MASK to X86_VM_MASK (which
> in turn defined as alias to X86_EFLAGS_VM) to better
> distinguish from virtual memory flags. We can't just
> use X86_EFLAGS_VM instead because it is also used
> for conditional compilation
>
> Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
> Signed-off-by: Ingo Molnar <mingo@elte.hu>


> --- a/include/asm-x86/vm86.h
> +++ b/include/asm-x86/vm86.h
> @@ -17,9 +17,9 @@
> #define IOPL_MASK 0x00003000
> #define NT_MASK 0x00004000
> #ifdef CONFIG_VM86
> -#define VM_MASK 0x00020000
> +#define X86_VM_MASK X86_EFLAGS_VM
> #else
> -#define VM_MASK 0 /* ignored */
> +#define X86_VM_MASK 0 /* No VM86 support */
> #endif
> #define AC_MASK 0x00040000
> #define VIF_MASK 0x00080000 /* virtual interrupt flag */

This is user-visible. Yet we're changing the name and also making it
depend on #ifdef CONFIG_VM86, which is not going to be set in userspace.
Perhaps it should be within #ifdef __KERNEL__?

--
dwmw2



\
 
 \ /
  Last update: 2008-04-23 04:21    [W:0.070 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site