[lkml]   [2008]   [Mar]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 4/5] cdrom: use list_head for cdrom_device_info list
On Sat, Mar 22 2008, Akinobu Mita wrote:
> Use list_head for cdrom_device_info list instead of opencoded
> singly list handling.

Looks good, but you don't seem to be initializing ->list anywhere. Did
you test this?

I'd suggest just adding an INIT_LIST_HEAD() before the list_add() in

You also seem to remove the !cdi check, which would be an unrelated

Jens Axboe

 \ /
  Last update: 2008-03-22 13:59    [W:0.089 / U:0.300 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site