lkml.org 
[lkml]   [2008]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: APM crashes when IO is going on
Date
On Friday, 21 of March 2008, Mikulas Patocka wrote:
> On Fri, 21 Mar 2008, Rafael J. Wysocki wrote:
>
> > On Friday, 21 of March 2008, Mikulas Patocka wrote:
> > > > > I found another problem --- present in 2.6.23.1, 2.6.25rc3, 2.6.25rc6
> > > > >
> > > > > --- when I run three threads concurrently reading raw disk partition and
> > > > > suspend, I get 100% reproducible failure. (with one thread running it
> > > > > usually succeeds, sometimes fail)
> > > >
> > > > Are they userland threads or kernel threads?
> > >
> > > Useland threads. Just dd if=/dev/hda of=/dev/null
> > >
> > > > > Either the on-going I/O will jam BIOS and I need to remove power to
> > > > > continue.
> > > > >
> > > > > Or the machine suspends, wakes up and reports "hda: lost interrupt"
> > > > > (2.6.23.1 was able to recover from this condition, 2.6.25rc3,6 does not
> > > > > recover and it is not able to send any more disk IOs).
> > > > >
> > > > > How is suspending disk IO supposed to work?
> > > >
> > > > That depends on the driver, if I understand your question correctly.
> > >
> > > The driver is normal IDE.
> >
> > Do you mean IDE_GENERIC/BLK_DEV_GENERIC?
>
> Compaq Triflex IDE. The computer is Compaq Armada 7400 (Pentium 2/300MHz)

Can you attach a dmesg output taken after a fresh boot?

Thanks,
Rafael


\
 
 \ /
  Last update: 2008-03-22 00:11    [W:0.071 / U:0.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site