lkml.org 
[lkml]   [2008]   [Mar]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/5] ptrace: it is fun to strace /sbin/init
On 03/16, Roland McGrath wrote:
>
> > Ptracing of /sbin/init is not allowed. Of course, this is very dangerous, but
> > may be useful. Introduce the kernel boot parameter to allow this.
>
> Personally I wouldn't mind losing all the ptrace/signals special cases for
> init. (Just don't have a buggy init and expect not to crash, don't be root
> and kill init, etc.) So this is fine by me. The conservative route of
> changing it only with a boot option is the wise thing to do.

Great.

> > Unless I missed something, ptrace_get_task_struct() is pointless. It does not
> > need to check "pid == 1", ptrace_attach() does this. It doesn't need tasklist.
>
> Agreed. It's a hold-over from when there was more hair in there.
>
> > It should be replaced with the generic find_get_task_by_vpid() which does not
> > exist yet.
>
> I didn't see enough other uses to really warrant it. Most
> find_task_by_vpid calls don't actually do get_task_struct.
> Those that do want to do some other check inside rcu_read_lock
> before deciding to bother with get_task_struct anyway.
> So there is nothing wrong with ptrace just open-coding:
>
> rcu_read_lock();
> child = find_task_by_vpid(pid);
> if (child)
> get_task_struct(child);
> rcu_read_unlock();

proc_task_lookup(), fill_pid(), attach_task_by_pid(), can use the new helper.

But yes sure, we can open-code this.

Oleg.



\
 
 \ /
  Last update: 2008-03-17 00:21    [W:0.056 / U:3.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site