lkml.org 
[lkml]   [2007]   [Jun]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Intel-IOMMU 02/10] Library routines for handling pre-allocated pool of objects
On Tue, Jun 05, 2007 at 04:30:48PM -0400, Jeff Garzik wrote:
> On Tue, Jun 05, 2007 at 01:24:33PM -0700, Keshavamurthy, Anil S wrote:
> > 1 file changed, 65 insertions(+), 19 deletions(-)
> >
> > Index: linux-2.6.22-rc3/lib/respool.c
> > ===================================================================
> > --- linux-2.6.22-rc3.orig/lib/respool.c 2007-06-05 12:22:26.000000000 -0700
> > +++ linux-2.6.22-rc3/lib/respool.c 2007-06-05 12:58:01.000000000 -0700
> > @@ -67,6 +67,7 @@
> > {
> > unsigned long flags;
> > struct list_head *plist = (struct list_head *)vaddr;
> > + bool queue_work = 0;
>
> Seems sane to me.
Thanks so much.

>
> I only have a very minor nit to pick: naming a variable (queue_work)
> the same as a public function may cause confusion.
>
> Also, if its a bool you should initialize it to 'true' or 'false'.
I will address when this patch gets into Andrew's mm tree.

Thanks once again,
Anil

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-06-05 23:03    [W:0.079 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site