lkml.org 
[lkml]   [2007]   [Jun]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ALSA: more section mismatches
At Thu, 28 Jun 2007 15:39:49 -0700,
Andrew Morton wrote:
>
> On Thu, 28 Jun 2007 15:05:15 -0700
> Randy Dunlap <randy.dunlap@oracle.com> wrote:
>
> > From: Randy Dunlap <randy.dunlap@oracle.com>
> >
> > Fix section mismatch warnings:
> >
> > WARNING: sound/built-in.o(.exit.text+0x3ad): Section mismatch: reference to .init.text: (between 'sb_exit' and 'unload_uart6850')
> > WARNING: sound/built-in.o(.exit.text+0x753): Section mismatch: reference to .init.text: (between 'snd_mts64_module_exit' and 'snd_portman_module_exit')
> >
> > Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
> > ---
> > sound/drivers/mts64.c | 2 +-
> > sound/oss/sb_card.c | 2 +-
> > 2 files changed, 2 insertions(+), 2 deletions(-)
> >
> > --- linux-2622-rc6.orig/sound/drivers/mts64.c
> > +++ linux-2622-rc6/sound/drivers/mts64.c
> > @@ -1048,7 +1048,7 @@ static struct platform_driver snd_mts64_
> > /*********************************************************************
> > * module init stuff
> > *********************************************************************/
> > -static void __init_or_module snd_mts64_unregister_all(void)
> > +static void snd_mts64_unregister_all(void)
>
> Well this is called from __exit, so __init_or_module isn't right. But we
> don't have an __exit_or_module.

Well, the name is a bit confusing. As Adrian pointed, it's called
_only_ from init or module.

>
> > {
> > int i;
> >
> > --- linux-2622-rc6.orig/sound/oss/sb_card.c
> > +++ linux-2622-rc6/sound/oss/sb_card.c
> > @@ -290,7 +290,7 @@ static struct pnp_card_driver sb_pnp_dri
> > MODULE_DEVICE_TABLE(pnp_card, sb_pnp_card_table);
> > #endif /* CONFIG_PNP */
> >
> > -static void __init_or_module sb_unregister_all(void)
> > +static void sb_unregister_all(void)
> > {
> > #ifdef CONFIG_PNP
> > if (pnp_registered)
>
> One of these is alsa and the other isn't.
>
> But what the heck: obviously safe, I'll slam it all in.

Yes, I'll merge them to ALSA tree, too.
A few bytes of diet won't be a big win in comparison with annoyance by
compiler warnings. ... Or, fix the tool!


Takashi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2007-06-29 19:29    [W:0.035 / U:0.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site