lkml.org 
[lkml]   [2007]   [Dec]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH]: Atmel Serial Console interrupt handler splitup
On Tue, 18 Dec 2007 12:08:05 +0200
"Andrew Victor" <avictor.za@gmail.com> wrote:

> > #define at_readl(port, off) __raw_readl((port)->membase + (off))
> > #define at_writel(v, port, off) __raw_writel(v, (port)->membase + (off))
> >
> > #define UART_PUT_CR(port, v) at_writel(v, port, ATMEL_US_CR)
> > #define UART_PUT_MR(port, v) at_writel(v, port, ATMEL_US_MR)
>
> I'd like to point out this relatively recent change to CodingStyle.
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=dff4982f5cd4e30e2a140a3bca95d8814115bf5b
>
> So I don't see a reason for complicating the code by adding additional
> macro's just to fit it in 80 column's.

Hmm...yes, I think that change to the CodingStyle makes sense. But I
guess the question is whether the old code "significantly increases
readability" and whether the new code "hides information".

I don't think so, but I don't feel all that strongly about it. I'd
actually prefer if we used at_writel() and at_readl() throughout the
code and killed those UART_PUT/UART_GET macros.

Haavard


\
 
 \ /
  Last update: 2007-12-18 11:33    [W:0.109 / U:0.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site