lkml.org 
[lkml]   [2006]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] add process_session() helper routine
On Tue, 17 Oct 2006 10:37:44 +0200
Cedric Le Goater <clg@fr.ibm.com> wrote:

> This patch replaces occurences of task->signal->session by a new
> process_session() helper routine.
>
> It will be useful for pid namespaces to abstract the session pid
> number.

hm.

> +static inline pid_t process_session(struct task_struct *tsk)
> +{
> + return tsk->signal->session;
> +}
> +

We should rename signal_struct.session to something else
(session_dont_use_me_directly) so that any code which accidentally fails to
use the wrapper will reliably fail to build.

That means that we'll also need a helper function to set this field.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-10-17 23:55    [W:0.063 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site