lkml.org 
[lkml]   [2003]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: sys32_ioctl -> compat_ioctl -- generic
On Tue, 4 Mar 2003 00:21:22 +0100 Pavel Machek <pavel@ucw.cz> wrote:
>
> +asmlinkage long compat_ioctl(unsigned int fd, unsigned int cmd, unsigned long arg)

For consistancy, this should be called compat_sys_ioctl.

> +{
> + struct file * filp;

> + filp = fget(fd);

> + /* find the name of the device. */
> + if (path) {
> + struct file *f = fget(fd);

Is it really necessary to do another fget(fd) ?

Also, if you are adding this much code, you should add a copyright notice
to the top of the file ...

--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.036 / U:0.560 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site