lkml.org 
[lkml]   [2002]   [Nov]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: New kconfig: Please add define_*
From
Date
Roman Zippel <zippel@linux-m68k.org> writes:
> Also note that the role of the default has changed, a default cannot
> override a prompt anymore (it only provides a default value to the
> prompt). The define_* syntax might imply that this is possible, but it
> won't.

I'd like to be able to override a prompt.

The reason is that in general it's nice for the arch-specific Kconfig
file to include various other Kconfig files (using `source'), but
sometimes an option that usually makes sense as user-definable -- and
thus has a prompt -- _doesn't_ make sense on that particular
architecture.

Currently it seems as if the arch-specific Kconfig can do several things
in this case:

(1) Inline the more general Kconfig into the arch-specific Kconfig
(with the offending option removed, and omit the `source'). This
is undesirable for all the usual reasons (code duplication causes
bit-rot etc).

(2) Document somewhere that users shouldn't ever set option FOO, even
though it asks the question. This is confusing for users.

(3) Add a dependency on ARCH_BLAH or something to the definition of
FOO. This is probably the cleanest solution, but tends to result in
arch-specific knowledge being littered all over the place (though
this is already a general problem with the config system).

It would nice if I could just say in my arch-specific Kconfig:

option FOO
bool
set n

which would force FOO to `n' regardless of any later declarations.

-Miles
--
`Life is a boundless sea of bitterness'
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:31    [W:0.623 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site