lkml.org 
[lkml]   [2020]   [Dec]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH v2 4/8] usb: chipidea: tegra: Rename UDC to USB
From
Date
17.12.2020 16:36, Thierry Reding пишет:
> On Thu, Dec 17, 2020 at 12:40:03PM +0300, Dmitry Osipenko wrote:
>> Rename all occurrences in the code from "udc" to "usb" and change the
>> Kconfig entry in order to show that this driver supports USB modes other
>> than device-only mode. The follow up patch will add host-mode support and
>> it will be cleaner to perform the renaming separately, i.e. in this patch.
>>
>> Tested-by: Matt Merhar <mattmerhar@protonmail.com>
>> Tested-by: Nicolas Chauvet <kwizart@gmail.com>
>> Tested-by: Peter Geis <pgwipeout@gmail.com>
>> Tested-by: Ion Agorria <ion@agorria.com>
>> Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
>> ---
>> drivers/usb/chipidea/Kconfig | 2 +-
>> drivers/usb/chipidea/ci_hdrc_tegra.c | 78 ++++++++++++++--------------
>> 2 files changed, 40 insertions(+), 40 deletions(-)
>>
>> diff --git a/drivers/usb/chipidea/Kconfig b/drivers/usb/chipidea/Kconfig
>> index 8bafcfc6080d..8685ead6ccc7 100644
>> --- a/drivers/usb/chipidea/Kconfig
>> +++ b/drivers/usb/chipidea/Kconfig
>> @@ -53,7 +53,7 @@ config USB_CHIPIDEA_GENERIC
>> default USB_CHIPIDEA
>>
>> config USB_CHIPIDEA_TEGRA
>> - tristate "Enable Tegra UDC glue driver" if EMBEDDED
>> + tristate "Enable Tegra USB glue driver" if EMBEDDED
>> depends on OF
>> depends on USB_CHIPIDEA_UDC
>> default USB_CHIPIDEA
>> diff --git a/drivers/usb/chipidea/ci_hdrc_tegra.c b/drivers/usb/chipidea/ci_hdrc_tegra.c
>> index 10eaaba2a3f0..d8efa80aa1c2 100644
>> --- a/drivers/usb/chipidea/ci_hdrc_tegra.c
>> +++ b/drivers/usb/chipidea/ci_hdrc_tegra.c
>> @@ -12,7 +12,7 @@
>>
>> #include "ci.h"
>>
>> -struct tegra_udc {
>> +struct tegra_usb {
>> struct ci_hdrc_platform_data data;
>> struct platform_device *dev;
>>
>> @@ -20,15 +20,15 @@ struct tegra_udc {
>> struct clk *clk;
>> };
>>
>> -struct tegra_udc_soc_info {
>> +struct tegra_usb_soc_info {
>> unsigned long flags;
>> };
>>
>> -static const struct tegra_udc_soc_info tegra_udc_soc_info = {
>> +static const struct tegra_usb_soc_info tegra_udc_soc_info = {
>> .flags = CI_HDRC_REQUIRES_ALIGNED_DMA,
>> };
>>
>> -static const struct of_device_id tegra_udc_of_match[] = {
>> +static const struct of_device_id tegra_usb_of_match[] = {
>> {
>> .compatible = "nvidia,tegra20-udc",
>
> Do we perhaps also want to add a new tegra20-usb compatible string here
> and deprecate the old one since this now no longer properly describes
> the device.

Ideally it should have been "tegra20-otg" to match TRM, but UDC is also
okay since it's a part of OTG and kinda presumes the OTG support of USB1
controller for anyone who read the TRM. Hence there is no need to change
the compatible, IMO.

> In either case, this looks fine:
>
> Acked-by: Thierry Reding <treding@nvidia.com>
>

thanks

\
 
 \ /
  Last update: 2020-12-17 15:02    [W:0.126 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site