lkml.org 
[lkml]   [2006]   [Dec]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Want comments regarding patch

On Dec 29 2006 07:57, Daniel Marjamäki wrote:
>
> It was my goal to improve the readability. I failed.
>
> I personally prefer to use standard functions instead of writing code.
> In my opinion using standard functions means less code that is easier to read.

Hm in that case, what about having something like

void *memset_int(void *a, int x, int n) {
asm("mov %0, %%esi;
mov %1, %%eax;
mov %2, %%ecx;
repz movsd;",
a,x,n);
}

in include/asm-i386/ and asm-x86_64/? (For x86_64, also a memset_long
that uses rsi/rax/rcx/movsq)


-`J'
--
\
 
 \ /
  Last update: 2006-12-29 11:17    [W:0.065 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site