lkml.org 
[lkml]   [2024]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6] Add multicolor support to BlinkM LED driver
Hello Joseph,

Am Fri, May 03, 2024 at 06:26:36PM -0500 schrieb Joseph Strauss:
> On 24/05/03 09:57AM, Lee Jones wrote:
> > On Sun, 28 Apr 2024, Joseph Strauss wrote:
> >
> > > Add multicolor support to the BlinkM driver, making it easier to control
> > > from userspace. The BlinkM LED is a programmable RGB LED. The driver
> > > currently supports only the regular LED sysfs class, resulting in the
> > > creation of three distinct classes, one for red, green, and blue. The
> > > user then has to input three values into the three seperate brightness
> > > files within those classes. The multicolor LED framework makes the
> > > device easier to control with the multi_intensity file: the user can
> > > input three values at once to form a color, while still controlling the
> > > lightness with the brightness file.
> > >
> > > The main struct blinkm_led has changed slightly. The struct led_classdev
> > > for the regular sysfs classes remain. The blinkm_probe function checks
> > > CONFIG_LEDS_BLINKM_MULTICOLOR to decide whether to load the seperate
> > > sysfs classes or the single multicolor one, but never both. The
> > > blinkm_set_mc_brightness() function had to be added to calculate the
> > > three color components and then set the fields of the blinkm_data
> > > structure accordingly.
> > >
> > > Signed-off-by: Joseph Strauss <jstrauss@mailbox.org>
> > > ---
> > > Changes in v2:
> > > - Replaced instances of the constant 3 with NUM_LEDS, where applicable
> > > - Fixed formatting errors
> > > - Replaced loop inside of blinkm_set_mc_brightness() with equivalent
> > > statements
> > > - Changed id of multicolor class from 4 to 3
> > > - Replaced call to devm_kmalloc_array() with devm_kcalloc()
> > > Changes in v3:
> > > - Add CONFIG_LEDS_BLINKM_MULTICOLOR to check whether to use multicolor
> > > funcitonality
> > > - Extend well-known-leds.txt to include standard names for RGB and indicator
> > > LEDS
> > > - Change name of Blinkm sysfs class according to well-known-leds.txt
> > > - Simplify struct blinkm_led and struct blinkm_data
> > > - Remove magic numbers
> > > - Fix formatting errors
> > > - Remove unrelated changes
> > > Changes in v4:
> > > - Fix indentation
> > > - Add default case to switch statement
> > > Changes in v5:
> > > - Fix warnings related to snprintf on s390 architecture, reported by
> > > 0-DAY CI Kernel Test Service
> > > Changes in v6:
> > > - Refactored struct blinkm_led to use a union
> > > - Refactored blinkm_probe()
> > > - Clarified documentation
> > >
> > > Documentation/leds/leds-blinkm.rst | 31 +++-
> > > Documentation/leds/well-known-leds.txt | 8 +
> > > drivers/leds/Kconfig | 8 +
> > > drivers/leds/leds-blinkm.c | 223 +++++++++++++++++--------
> > > 4 files changed, 198 insertions(+), 72 deletions(-)
> >
> > Just tried to apply this, but checkpatch.pl has some complaints.
> >
> > Please fix them and resubmit, thanks.
> >
> > --
> > Lee Jones [李琼斯]
> I fixed the errors and warnings that resulted from my patch, but am
> I correct in assuming I am not responsible for fixing the warnings
> from other parts of the file? It would make the patch messier is my
> concern.

I would say so. Output somehow depends on what you call checkpatch
with. Passing the actual patch (after `git format-patch …`) you
should only get warnings for parts you touched. Passing the whole
file with -f of course you also get warnings for other parts.

Greets
Alex


\
 
 \ /
  Last update: 2024-05-27 18:16    [W:0.065 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site